Themergency fooplugins.com

“event.layerX…deprecated in Webkit” Warnings in Chrome

| 2 Comments

UPDATE 16 May 2012 : It seems these warnings have finally been removed from Chrome - https://bugs.webkit.org/show_bug.cgi?id=86264

While writing a blog post the other night I noticed my WordPress admin was really slow and not as responsive as it usually is. I use Chrome mostly, so I opened up my developer tools to have a looks what was going on. This is what I saw:

Over 6000 javascript warnings! WTF!!!?? The full warning is:

event.layerX and event.layerY are broken and deprecated in WebKit. They will be removed from the engine in the near future.

So I did the next logical thing: I Googled it. It turns out that the latest release of Chrome and jQuery 1.6 do not play nicely.

This Stack Overflow article gives some more hints. It turns out this can be fixed by upgrading to jQuery 1.7, but the problem is the current version of WordPress (3.2.1) uses jQuery 1.6!

So, my next question is

When will WordPress 3.3 be released??

1 comments
  Livefyre
  • Get Livefyre
  • FAQ
ChrisMorrisCo
ChrisMorrisCo

I ran into a similar issue today, but I found that the problem wasn't jQuery but rather an extension I had enabled in Chrome. If you're still getting the errors, maybe try disabling your extensions.

I wrote about it here, if you're interested - http://chrismorris.co/2012/02/11/have-you-disabled-extensions-a-story-of-javascript-debugging-with-a-shocking-twist/